В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
JaspeR9
JaspeR9
17.08.2021 00:12 •  Информатика

Напишите программу, которая в последовательности n натуральных чисел определяет максимальное число, кратное 4. программа получает на вход n-ное количество чисел. в последовательности всегда имеется число, кратное 4. программа должна вывести одно число — максимальное число, кратное 4.

Ответ:
0689433382
0689433382
05.07.2020 16:49
var
  i, n, k, max: integer;

begin
  readln(n);
  max := Integer.MinValue;
  for i := 1 to n do
  begin
    readln(k);
    if (k mod 4 = 0) then
      max := System.Math.Max(max, k);
  end;
  writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?