В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Препод007
Препод007
03.06.2023 10:12 •  Информатика

(составить программы в паскале): напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла , а вывод – (в скобках указана размерность массива): увеличить каждый третий элемент массива в 2 раза (12)напишите программу, в которой нужно для каждой строки двухмерного массива 5 на 4 определить максимальное значение

Ответ:
diman211102
diman211102
05.07.2020 15:25

var

a:array[1..5,1..4]of integer;

max,i,j:integer;

begin

for i:=1 to 5 do begin

for j:=1 to 4 do begin

a[i,j]:=random(10);

write(a[i,j],' ');

end;

writeln;

end;

for i:=1 to 5 do begin

max:=a[i,1];

for j:=1 to 4 do

if a[i,j]>max then max:=a[i,j];

writeln(max);

end;

end.

2 задача

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?