Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Вика6789754
04.04.2020 15:55 •
Информатика
С++ написать программу перевода из десятичного числа в двоичное.
Ответ:
Kiryshka2532
05.07.2020 13:02
#include <iostream>
using namespace std;
void bin(int n);
int main()
{
int n;
cout<<"Введи число в десятичной системе счисления\n";
cin>>n;
bin(n);
system("pause");
return 0;
}
void bin(int n)
{
int binn[15], ;
for(int i=14;i>=0; i--)
{
binn[i]=n % 2;
n=n/2;
}
for(int i=0; i<=14;i++)
{
cout<<binn[i];
}
cout<<"\n";
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Zena1112
30.09.2021 05:44
Вребусе зашифрованно название устройства для компьютера. на ребусе нарисовано *1 о о д * 1- диск здоровья * о- о (буква ) * о-тоже * д-находится во 2 букве о ( внутри) для...
GranMartin
29.04.2020 20:56
)надо сделать отчет program prog; uses crt; var a: array[1..10] of integer; s,i,max, min: integer; sr: real; begin clrscr; min: =a[1]; for i: =1 to 10 do begin write( a[ ,i,...
Filka7
22.01.2023 06:51
Опишите инструменты и их функции.информатика...
Coolboy1213
12.05.2022 16:43
с заданием: Какие макеты использованы для каждого слайда и почему?:...
freddylolbrO
20.12.2020 09:53
9,7 в десятичной перевести в двоичную 43,2 в десятичной перевести в двоичную по расширенней написать 15...
zoonadin
14.01.2022 17:11
70. Спишіть подані речення. Визначте їх за метою висловлювання. Укажіть, який порядок слів використано в кожному реченні. 1. Уранці Уляна взяла кошик і пішла наламати кукурудзи...
sofyagorobecmaozu3v3
28.02.2023 22:11
Запиши в виде многочлена квадрат двучлена, заполнив пропуски.1. (x + y)² = ...² + ... + y²2. (m - n)² = ... + n²3. (2a + 5b)² = 4 ...² + ... + ...²4. (3x - 2y)² = ...5. (0,5m...
Kotyanya
17.09.2022 10:45
1. Які органи належать до внутрішніх?...
школаскучаю
27.06.2020 07:09
Что будет если на потертую картошку капнуть перекись водорода...
05gazieva05
17.05.2022 13:09
. Кто такой Карл Мартелл? какую реформу он провел? В чем её суть? Какую пользу франком принесла эта реформа...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
void bin(int n);
int main()
{
int n;
cout<<"Введи число в десятичной системе счисления\n";
cin>>n;
bin(n);
system("pause");
return 0;
}
void bin(int n)
{
int binn[15], ;
for(int i=14;i>=0; i--)
{
binn[i]=n % 2;
n=n/2;
}
for(int i=0; i<=14;i++)
{
cout<<binn[i];
}
cout<<"\n";
}