В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastyaivanko09
nastyaivanko09
14.04.2023 21:51 •  Информатика

Огэ 20.2. паскаль. требовалось написать программу, определяющую количество трехзначных чисел, кратных 3. я написал: if (x> 99) and (x< 999)and (x mod = 0) then i: = i+1 снимут ли за (x< 999) ,а не (x< 1000)

Ответ:
nadyasvetlakov
nadyasvetlakov
05.07.2020 12:24

Var

A:array[1..3]of integer;

P,k:integer;

Begin

P:=3;

While p>0 do begin

If a[p]<9 then begin

Inc(a[p]);

P:=3;

If (a[1]>0)and((a[1]*100+a[2]*10+a[3]) mod 3 = 0 then inc(k);

End

Else begin

A[p]:=0;

P:=p-1;

End;

End;

Writeln(k);

End.

Попробуй эту прогу

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?