В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0224n
0224n
05.10.2022 00:34 •  Информатика

Составьте программу печати таблицы температур по цельсию от 0 до градусов с шагом в один градус и их эквивалентов по шкале фаренгейта используя для перевода формулу tf=9tc/5+32

Ответ:
natashenkagrekova357
natashenkagrekova357
05.07.2020 12:20
var
  max, i: integer;
  
begin
  readln(max);
  for i := 0 to max do
    writeln(i:3, chr(0176), 'C | ', 9 * i / 5 + 32, chr(0176), 'F');
end.

Элементарная домашка... Не знаю, прочтёт ли это кто-нибудь, но...
Считываем верхнюю границу вывода (ибо в условии с ней заминка), а затем в столбик выводим... chr() возвращает символ по коду, а 176 - код градуса
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?