Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Illia1Z
23.04.2022 14:39 •
Информатика
Напишите программу на с++ -"нахождение среднего арифметического из n чисел"
Ответ:
даша55516
05.07.2020 10:11
#include <stdio.h>
#include <conio.h>
float get_cpedn_aref(int N)
{
int sum = 0, n;
for(int i = 0; i < N; ++i)
{
printf("\n\t%d. -> ", i);
scanf("%d", &n);
sum += n;
}
return sum / N;
}
int main()
{
int N = 0;
printf("Enter N: \n\t-> ");
scanf("%d", &N);
printf("\nCpednee apifmeti4eckoe: \n\t %f", get_cpedn_aref(N));
getch();
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
katenabulasheva
01.11.2022 11:45
# coins - это количество монет. Можете заменить coins на другое название, если хотите coins = 0 # Здесь нужно начать бесконечный цикл while # Используйте input, чтобы...
ILiveYou
06.10.2022 02:23
Как можно решить. какие условия я должен поставить...
helenawoy
18.01.2022 17:12
Из двоичной в десятичную: 111011; 1111...
Фоксе2121
17.05.2022 23:22
ОТВЕТИТЬ НА 1 ЛЕГКИЙ ВОПРОС...
panerik6
24.11.2020 09:29
Запишите маску, которая позволяет сгруппировать все файлы, расширение имени которых состоит из одного символа: *...
Yskakova206
13.08.2020 03:18
Даны три действительных числа возвести в квадрат те из них, значения которых отрицательны. неотрицательные оставить без изменения(Pascal)напишите программу...
fenix8383
17.12.2021 06:03
Написати програму c++, в якій створити class Human з полями name, day, mоnth, year, та методом age(), який обчислює віклюдини....
muskuss12Ирада
06.03.2022 21:46
2. Вася решил дополнить программу так, чтобы она выводила сообщение с его именем.Он записал оператор вывода так:вывод Привет, Вася!write (Привет , Вася! )Эта программа...
Swerri
24.10.2022 19:21
В «Детском мире» продавали двухколёсные и трёхколёсные велосипеды. Максим пересчитал все рули и все колёса. Получилось 18рулейи 41колёс...
shakirovbulat9
24.10.2022 19:21
Прочитай текст и изобрази семейное дерево, включающее всех перечисленных в тексте родственников. Впиши в прямоугольники на...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <conio.h>
float get_cpedn_aref(int N)
{
int sum = 0, n;
for(int i = 0; i < N; ++i)
{
printf("\n\t%d. -> ", i);
scanf("%d", &n);
sum += n;
}
return sum / N;
}
int main()
{
int N = 0;
printf("Enter N: \n\t-> ");
scanf("%d", &N);
printf("\nCpednee apifmeti4eckoe: \n\t %f", get_cpedn_aref(N));
getch();
return 0;
}