В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sofa22Bas
Sofa22Bas
17.12.2022 19:03 •  Информатика

Требуется отсортировать массив по неубыванию методом "пузырька". в первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. во второй строке nчисел – элементы массива (целые числа, не превосходящие по модулю 1000). на с++ !

Ответ:
jvhhvcx
jvhhvcx
05.07.2020 09:54
A:array[1..1000] of integer;
i, k, z, n, j:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n-1 do
for j:=1 to n-i do
if a[j]>a[j+1] then begin
z:=a[j]; a[j]:=a[j+1]; a[j+1]:=z; end;
for i:=1 to n do
writeln(a[i]);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?