В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alona7773
alona7773
18.02.2023 16:45 •  Информатика

По паскалю.условный оператор. 1.даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением. 2.найдите решение уравнения ах+ в=0, если оно существует,если а=0 3.написать программу удвоения меньшего из двух чисел

Ответ:
MonstorXXXX
MonstorXXXX
01.10.2020 19:09
1)
program chik2;
var a,b,c:real;
begin
readln(a,b);
if(a<b)then begin
c:=a;
a:=(a+b)/2;
b:=b*c;
end;
if(a>=b)then begin
c:=b;
b:=(a+b)/2;
a:=a*c;
end;
writeln(a,' ',b);
end.
2)
program chik;
var a,x,b:real;
begin
readln(a,b);
if(a=0)and(b<>0)then writeln('НЕТ решений');
if(a<>0)then begin
 x:=-b/a;
writeln(x);
end;
end.
3)

program chik3;
var a,b:real;
begin
readln(a,b);
if(a<b)then a:=a*2 else
if(b<a)then b:=b*2;
writeln(a,' ',b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?