В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Samira543
Samira543
02.11.2020 21:32 •  Информатика

Напишите программу для решения . с2.даны целые числа a,b,с.если а≤b≤c,то все числа замените квадратами,если а> b> c,то каждое число замените наибольшим из них,в противном случае смените знак каждого числа. с2.по номеру месяца выдайте квартал,которому он принадлежит.

Ответ:
pasagilazutdino
pasagilazutdino
05.07.2020 07:35
Var a,b,c:integer;
begin
readln(a,b,c);
if (a<=b) and (b<=c) then
begin
a:=a*a;
b:=b*b;
c:=c*c;
end
else if (a>b) and (b>c) then
begin
if a<b then a:=b;
if a<c then a:=c;
b:=a; c:=a;
end 
else     
begin       
a:=a*(-1);       
b:=b*(-1);       
c:=c*(-1)     
end; 
writeln(a:4, b:4, c:4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?