В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sun54
sun54
04.04.2023 23:55 •  Информатика

Написать программу в паскале: 1.дано целое число. вычислить, если возможно, натуральный логарифм этого числа и вывести его на экран. в противном случае вывести сообщение об ошибке.

Ответ:
09876нг8678
09876нг8678
05.07.2020 07:00
Логарифм существует только для положительных чисел.
Поэтому напишем такую программу:

var  x:integer;
BEGIN
writeln('Введите число');
readln(x);
if  x<=0 then 
     writeln('Логарифм этого числа не существует')
     else write('ln=',ln(x))
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?