В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
мария564384
мария564384
30.04.2022 06:51 •  Информатика

1.написать программу, которая проверяет, образуют ли элементы введенного с клавиатуры массива неубывающую последовательность. 2.вставить число а перед всеми элементами, большими а, а число в - после всех элементов, меньших его. 3.дана матрица ф(6х7), заполненный случайным образом. заменить максимальный элемент каждой строки на противоположный по знаку. 4. дан двумерный массив. найти сумму элементов его главной диагонали и поизведение элементов побочной диагонали. результат занести в одномерный массив. , , нужно! хотя бы некоторые решите. второй день не могу сделать! тема одномерных и двумерных массивов.

Ответ:
klimenkol21
klimenkol21
03.07.2020 22:51
                                           НАПИСАНО НА ПАСКАЛЕ!
2)

program fofgogjoj;
const nmax=100;
var
m:array[1..nmax] of integer;    
n,i,j,k:byte;    
a,b,x:integer;
begin
randomize;
repeat Write('Размер массива до ',nmax div 3,' n=');
readln(n);
until n in [1..nmax div 3];
Writeln('Исходный массив:');
for i:=1 to n do  
begin
m[i]:=random(50);  
Write(m[i],' ');  
end;
Writeln;
Writeln;
Write('Введите число для вставки перед a=');
Readln(a);
i:=1;
k:=0;
while i<=n do  
begin
if m[i]>a then    
begin    
n:=n+1;    
k:=1;    
for j:=n downto i+1 do    
m[j]:=m[j-1];    
m[i]:=a;    
i:=i+2;    end  
else i:=i+1;  
end;
if k=0 then
Writeln('Элементов больше ',a,' нет')
else  
begin  
Writeln('Массив после вставки числа ',a,' перед большими ',a);  
for i:=1 to n do  
Write(m[i],' ');  
Writeln;  
Writeln;  
Write('Введите число для вставки после b=');  
Readln(b);  
i:=1;k:=0;  
while i<=n do  
if m[i]<b then    
begin    
n:=n+1;    
k:=1;    
for j:=n downto i+2 do    
m[j]:=m[j-1];    
m[i+1]:=b;    
i:=i+2;    end  
else
i:=i+1;  
if k=0 then
Writeln('Элементов меньше ',b,' нет')  
else    
begin    
Writeln('Массив после вставки числа ',b,' после меньших ',b);    
for i:=1 to n do    
Write(m[i],' ');    
end;  
end;
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?