В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Азим721
Азим721
30.03.2023 10:42 •  Информатика

Необходимо написать программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2.программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, оканчивающееся на 2.количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число — максимальное число, оканчивающееся на 2.

Ответ:
AngelGelay
AngelGelay
25.05.2020 03:08

var n,a,i,max:integer;

begin

readln(n);

max:=0;

for i:=1 to n do

begin

read(a);

if (a mod 10=2)and(a>max) then max:=a;

end;

writeln(max);

end.

Пример:

17 20 12 41 15 5 52 10

52

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?