В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
WaysWhite
WaysWhite
09.06.2020 10:58 •  Информатика

Дан целочисленный массив из 70 элементов.элементы массива могут принимать целые значения от 0 до 100.составить программу ,позволяющую найти и вывести элементы массива, которые не кратны 9 и находятся в диапазоне[30,70].гарантируется,что в исходном массиве есть хотя бы один такой элемент.

Ответ:
настена0902
настена0902
01.10.2020 18:20
Const
    auto = true;
    n = 70;

var
    a: array[1..n] of integer;
    i: integer;

begin
    for i := 1 to n do
    begin
        if auto then
            a[i] := random(100)
        else readln(a[i]);
       
        if (a[i] <= 70) and (a[i] >= 30) and (a[i] mod 9 > 0) then
            writeln(a[i]);
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?