В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
daryanesterchuk
daryanesterchuk
16.03.2022 10:34 •  Информатика

Написать программу на с++найти количество четных цифр заданного натурального числа n

Ответ:
Nik10234
Nik10234
03.07.2020 19:27

#include <iostream>

#include <locale.h>

using namespace std;

int main()

{

setlocale(0, "Russian");

unsigned int n;

unsigned short int s = 0;

cout << "Введите натуральное число N:" << endl;

cin >> n;

do {

 if ((n % 10) % 2 == 0)

  s++;

}

while ((n /= 10) != 0);

cout << "Количество чётных цифр числа: " << s << endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?