Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Кристалина12
24.09.2022 12:17 •
Информатика
Написать программу в ! число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число.
Ответ:
snakesap
01.10.2020 18:04
Var a:string;
i,a1,ar:integer;b:real;
begin
readln(a);
b:=0;
for i:=1 to length(a) do
begin
val(a[length(a)-i+1],a1,ar);
b:=b+a1*exp((i-1)*ln(2));
end;
writeln('b=',b);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Locko3
10.09.2021 08:16
Прям очень нужно решите. Чертёжнику был дан для исполнения следующий алгоритм:Повтори 7 paзСместиться на (−1, 2) Сместиться на (−5, 2) Сместиться на (4, −4) КонецКакую команду...
mailiiti63
16.11.2020 14:26
Заполните таблицу,указав сходство и различие следеющих пар объектов: функции клавиш delete и backspace; перемещение по тексту с клавиш курсором и в режиме прокрутки; режимы вставки...
KristyLis
16.11.2020 14:26
Построить графики функции в паскале. (нужна сама программа) y= 1/(x2+1); y=cos(x2)....
RengevychPolina
16.11.2020 14:26
Слово содержит 17 символов. определить его объем в обычной кодировке: 119 байт 17 байт 34 байт 68 байт 19 байт...
Istominyura
30.07.2021 17:42
Как переводится целое число из десятичной в другую систему счисления...
1Raffaelka1
01.01.2023 09:28
1чему равны выражения `2`+`3` и `2`+`3` 2 чему равен код `5` , если код `0` равен 48 3 чему равно выражение ord(`2`)+ord(`3`)-96 4 какой тип имеет выражение `2`+`3` 25...
Pahnet
28.05.2023 11:46
Какой смысл обществоведы вкладывают в понятие социальные нормы ?...
tanya665444
28.05.2023 11:46
Определите массовую долю меди ii сульфата в растворе, добытом при растворении 25 г медного купороса в 375 г воды...
poolliinnaa
28.05.2023 11:46
Какой номер мурзилки самый новый 18 например...
Анастасияпрофи1
28.05.2023 11:46
Найдите сумму a^2 + 1/(a^2), если a - 1/a = 3/2...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,a1,ar:integer;b:real;
begin
readln(a);
b:=0;
for i:=1 to length(a) do
begin
val(a[length(a)-i+1],a1,ar);
b:=b+a1*exp((i-1)*ln(2));
end;
writeln('b=',b);
end.