В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Molka2005
Molka2005
05.09.2021 17:18 •  Информатика

1). дан массив из n чисел (n четное). написать программу миняющую местами элементы с четными и нечетными номерами 2). дан массив из n чисел. написать программу циклически сдвигающую элементы массива на 1 позицию вправо ( 7,8,9,10,15,14 ; 14,7,8,9,10,15)

Ответ:
coldon
coldon
01.10.2020 18:00
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 const   nmax = 20; var   A : array [1..nmax] of integer;   i, n, temp : integer; begin Randomize; Repeat Write('Размер массива: '); Readln(n); until n in [1..nmax]; Writeln('Исходный массив: '); for i := 1 to n do  begin  A[i] := random(30);  Write(A[i], ' ');  end; Writeln; Writeln('Массив после изменений: '); temp := a[n]; for i := n downto 2 do a[i] := a[i - 1]; a[1] := temp; for i := 1 to n do Write(A[i], ' '); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?