В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nnfilinaaaa
nnfilinaaaa
27.11.2020 22:55 •  Информатика

Нужно написать программу в паскале : с клавиатуры вводится число n. заполнить массив с клавиатуры n значениями и вывести их произведение.

Ответ:
moon455808
moon455808
03.07.2020 17:13
var
  a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
  n, i: byte;          //Больше и не пригодится, массива из 255 значений хватит уж
  l: Int64 := 1;      //Произведение - большая цЫферка

begin
  readln(n);
  System.Array.Resize(a, n);
  for i := 0 to (n - 1) do
  begin
    write('a[', i, '] = ');
    readln(a[i]);
    l *= a[i];
  end;
  writeln(l);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?