В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Polina2050
Polina2050
21.04.2022 21:27 •  Информатика

Написать программу которая выводит на экран значений функции у=|х|. диапазон изменения аргумента-от4 до -4, шаг приращения .5)

Ответ:
CoralineGilmor
CoralineGilmor
03.07.2020 16:21
Если я правильно понял,то так
uses crt;
varx,y:real;
beginx:=4;
while x>(-4.5) do begin
y:=abs(x);
x:=x+(-0.5);
write(y,' ');
end;
end.
0,0(0 оценок)
Ответ:
2566409
2566409
03.07.2020 16:21
Вот так:
const
  LB=-4;
  HB=4;
  DX=0.5;
var
  x,y : real;
  n,i :integer;
begin
   writeln('значения');
   n:=round((HB-LB)/DX)+1;
   x:=LB;
  for i:= 1 to n do
     begin
        y:=abs(x);
        writeln(x:6:2,y:6:2);
        x:=x+DX;
     end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?