В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olyakurets
olyakurets
06.10.2022 04:04 •  Информатика

Даны три натуральных числа. напишите программу в паскале , определяющую , существует ли треугольник с такими длинами сторон. если такой существует , то определите его тип (равносторонний , равнобедренный, разносторонний) ! заранее .

Ответ:
Var
a,b,c,k:integer;
begin
readln(a,b,c);
if (a+b>c)and(b+c>a)and(a+c>b) then begin
writeln('треугольник существует');
k:=1
end
else writeln('треугольник не существует');
if (a=b)and(a=c) and (k=1) then
writeln('равносторонний');
if (((a=b)and(a<>c))or((c=b)and(c<>a))or((c=a)and(c<>b)))and (k=1) then
writeln('равнобедренный');
if (a<>b)and(c<>b)and(a<>c)and (k=1) then
writeln('разносторонний')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?