В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NiceSaid
NiceSaid
08.12.2020 07:50 •  Информатика

Синформатикойнаписать программу,загадывает число, затем сравнивает его 3 раза со случайным сгенерированным числом.​

Ответ:
Ульяна122004
Ульяна122004
25.05.2020 02:50

var r_1,r_2,r_3,ch : integer;

begin

       writeln('ch = ');

       readln(ch);

       r_1 = random(50) - 25;  {рандомные числа в районе от -25 до 25}

       r_2 = random(50) - 25;

       r_3 = random(50) - 25;

       writeln('r_1 = ',r_1);

       writeln('r_2 = ',r_2);

       writeln('r_3 = ',r_3);

       if r_1 < ch then  

       begin

               writeln('r_1 < ch');

       end;

       if r_1 = ch then  

       begin

               writeln('r_1 = ch');

       end;

       if r_1 > ch then  

       begin

               writeln('r_1 > ch');

       end;

       if r_2 < ch then  

       begin

               writeln('r_2 < ch');

       end;

       if r_2 = ch then  

       begin

               writeln('r_2 = ch');

       end;

       if r_2 > ch then  

       begin

               writeln('r_2 > ch');

       end;

       if r_3 < ch then  

       begin

               writeln('r_3 < ch');

       end;

       if r_3 = ch then  

       begin

               writeln('r_3 = ch');

       end;

       if r_3 > ch then  

       begin

               writeln('r_3 > ch');

       end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?