В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sone4ka1111
Sone4ka1111
01.12.2022 02:02 •  Информатика

Надо составить программу, которая для любого натурального числа печатает количество цифр в записи этого числа. расписать все четко

Ответ:
NastiLife
NastiLife
01.10.2020 17:36
Строками:
var s:string;
begin
WriteLn('vvedi chislo:');
ReadLn(s);
WriteLn('chislo cifr=',length(s));
ReadLn;
end;
Не строками:
var N,k:longint;
begin
write('N=');readln(N);
k:=0;
while N>0 do
begin
N:=N div 10;
k:=k+1;
end;
write('k=',k);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?