В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
5434689
5434689
04.11.2022 22:03 •  Информатика

Паскаль. с клавиатуры введены 6 целых чисел. составьте программу, которая найдет из них наибольшее из них. использовать процедуру поиска большего из двух (бид).

Ответ:
Silestya
Silestya
25.05.2020 02:43

//PascalABC.NET 3.4.2

var x, max: integer;

procedure my_max(x1, x2: ^integer);

begin

 if (x2^ > x1^) then x1^ := x2^;

end;

begin

 loop 6 do

 begin

   x := readinteger();

   my_max(@max, @x);

 end;

 write(max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?