В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mkogavuk
mkogavuk
21.01.2021 22:04 •  Информатика

По данным x, y составить программу в паскале для вычисления функции z: 1) z=(min(x, y)+0,5))/(1+max^2(x, 2)z=система max(x, y), x< 0 min(x, y), x> =0.

Ответ:
пппппп41ррр
пппппп41ррр
03.07.2020 10:02
1)var x,y,z,min,max:real;
begin
readln(x,y);
if x>y then 
begin
max:=x;
min:=y;
end
else if x<y then
begin
max:=y;
min:=x;
end;
z:=(min+0.5)/(1+sqr(max));
writeln(z);
end.
2)var x,y,z,min,max:real;
begin
readln(x,y);
if x>y then
begin
max:=x;
min:=y;
end
else if x<y then
begin
max:=y;
min:=x;
end;
if x<0 then
z:=max
else if x>=0 then
z:=min;
writeln(z);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?