В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikagalimzhano
vikagalimzhano
06.11.2022 20:42 •  Информатика

Напишите программу которая определяет nod трех натуральных чисел (с использованием процедур)

Ответ:
DimitryPanika
DimitryPanika
03.07.2020 08:46
Var
 a,b,c:integer;
procedure main(a,b,c:integer);
var
 i,max,nod:integer;
begin
 if (a>b) and (a>c) then
  max:=a
 else
  if (b>a) and (b>c) then
   max:=b
  else
   max:=c;
 nod:=1;
 for i:=1 to max do
 begin
  if (a mod i = 0) and (b mod i = 0) and (c mod i = 0) then
   nod:=i;
 end;
 writeln(nod);
end;
begin
 read(a,b,c);
 main(a,b,c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?