В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
daniilfd
daniilfd
09.09.2022 12:50 •  Информатика

Написать программу! ! while и repeat 1)напечатать все отрицательные числа из диапазона от а до б, с шагом h. 2)напишите программу, при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

Ответ:
Апофис
Апофис
01.10.2020 16:56
1.program z;
var a,b,c:integer;
begin
read(a,b,c);
while (a<b) and (a<0) do
begin
write(a:4);
a:=a+c;
end;
end.
2.program z;
var a,b,c:integer;
begin
read(a,b,c);
repeat
write(a:4);
a:=a+c;
until (a>b) or (a>-1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?