В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mariyudina95
mariyudina95
16.08.2020 07:48 •  Информатика

Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.

Ответ:
KINGOFMATH1
KINGOFMATH1
01.10.2020 16:53
Var
    i, s1, s2, s3, s4, n: integer;

begin
    write('n = ');
    readln(n);
    s1 := 0;
    s2 := 0;
    s3 := 0;
    s4 := 0;
    
    for i := 1 to n do
    begin
        s1 := s1 + i;
        s2 := s2 + sqr(i);
        if i mod 2 = 0 then s3 := s3 + i;
    end;
    
    for i := 10 to 99 do s4 := s4 + i;
    
    writeln('Сумма первых n натуральных чисел: ', s1);
    writeln('Сумма квадратов первых n натуральных чисел: ', s2);
    writeln('Сумма всех четных чисел: ', s3);
    writeln('Сумма всех двухзначных чисел: ', s4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?