В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Карина2209
Карина2209
31.03.2020 10:18 •  Информатика

Составить программу вычисления значения функций в зависимости от интервала у=1+3х, при х< -2 1+xв квадрате, при -2< _x< _2 (x+1), при x> 2

Ответ:
Margo231
Margo231
02.07.2020 23:29
Var x,y:real;
begin
writeln ('Введите x');
readln (x);
if (x<-2) then y:=1+3*x;
if (x>=-2) and (x<=2) then y:=sqr(1+x); //по условию -2<_x<_2 я подумал, что _ значит =, если нет - удали равно здесь (x>=-2) and (x<=2)
if (x>2) then y:=x+1;
writeln ('Значение функции = ',y);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?