В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

:составить программу расчёта числа загонов (шт.) на пастбище по формуле: к=п/д+з, где п-период, необходимый для отрастания травы на пастбище, дн.; д- количество дней пастьбы для скота в каждом загоне, дн.; з- потребное количество загонов для возобновления травостоя, шт.; количество дней пастьбы скота изменяется в пределах от 1 до 5 дней с шагом 1 день.

Ответ:
Kuznezovamargo
Kuznezovamargo
02.07.2020 22:58
Program qq;
uses crt;
var p, d, z, i: integer; k:real;
begin
writeln('Введите период для отрастания травы в днях:');
readln(p);
writeln('Введите потребное количество загонов:');
readln(z);
for i:=1 to 5 do
    begin
    d:=i; // переменная дней изменяется, как дано в условии от 1 до 5 дней
    k:=round(p/d+z); //процедура round округляет по всем правилам число загонов. Ведь весьма нелогично строить, например 3,3333 загона:)
    writeln ('Для количества дней пастьбы - ', d,' требуется загонов - ',k);
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?