В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
урган1
урган1
18.12.2021 00:52 •  Информатика

Доброго времени суток. , составить программу в паскале. дана последовательность вещественных чисел, содержащих n=15 элементов. построить из неё новую последовательность, так чтобы в её начале располагались все отрицательные, а затем все положительные числа и нули. относительный порядок расположения как отрицательных, так и не отрицательных должен быть сохранён

Ответ:
anasasiyakoval
anasasiyakoval
02.07.2020 22:35
Var 
res,mas:array[1..100] of real; 
k,i:integer;
begin 
k:=0; 
for i:=1 to 15 do   
read(mas[i]); 
for i:=1 to 15 do  
begin   
if mas[i]<0 then     
write(mas[i],' ')   
else   
begin     
k:=k+1;     
res[k]:=mas[i];   
end; 
end; 
for i:=1 to k do   
write(res[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?