Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ainashsharipov
16.12.2022 00:41 •
Информатика
Напишите программу для того, чтобы в целом натуральном числе n поменять местами первую и последнюю цифру, с цикла while в pascal abc. за него 15 . , !
Ответ:
Cornelia1313
02.07.2020 22:31
Program chik;
var n,a,b,s,q,k:integer;
begin
readln(n);
q:=n mod 10;
while n>0 do
begin
b:=n mod 10;
n:=n div 10;
s:=s*10+b;
end;
n:=q;
s:=s div 10;
while s>10 do
begin
k:=s mod 10;
s:=s div 10;
n:=n*10+k;
end;
n:=n*10+b;
writeln(n);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vangok31
27.09.2021 06:21
исправить цикличную программу так , чтобы она находила произведение трёх чисел. Паскаль...
staroverovandr
13.02.2020 01:47
Произошла ошибка при распаковке: Невозможно считать данные! Unarc.dll вернул код ошибки: -6 ERROR: file read operation failed...
Teddy1bear
22.06.2021 21:14
Сравните объёмы возможности устройств передачи информации.Жёсткий диск и Лазерный диск...
Sasha2007ad
01.06.2023 15:40
Больше нуля Напишите программукоторая определяетбольше, меньше или равноПИ Введенное ЧИСЛО НУЛЮЕсли Число больше нуля,программа должнаВыводить сообщение Greater , если меньшенуля...
bulycheva0303
23.09.2022 18:15
«В»: Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне[10,100] и сортирует его по возрастанию последнейцифры числа (сначала идут...
lehareva
15.02.2023 22:33
Вычислить результат выполнения программы var d, t: integer;begind:=13;t:=3;t:=d mоd 4. ;t:=t div 3;writeln (d);end...
nuk890
22.04.2022 20:49
9) Для кодировки четырех букв: е л м о использовали следующие шестнадцатеричные коды: е- 10; л - 00; м- 01; o – 11Какое слово закодировано следующим двоичным кодом: 000000010001000100000000...
садов19
18.03.2023 23:52
Выразите 13 мбайт в битах 68 бит в кбайтах....
Zein304
12.12.2021 18:03
Сколько существует пятизначных чисел, у которых каждая следующая цифра меньше предыдущей?...
Nika31303
12.12.2021 18:03
Вструктуру деятельности входят: а)цель б)потребности ц)интересы д...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n,a,b,s,q,k:integer;
begin
readln(n);
q:=n mod 10;
while n>0 do
begin
b:=n mod 10;
n:=n div 10;
s:=s*10+b;
end;
n:=q;
s:=s div 10;
while s>10 do
begin
k:=s mod 10;
s:=s div 10;
n:=n*10+k;
end;
n:=n*10+b;
writeln(n);
end.