В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
лисичка009
лисичка009
28.05.2023 23:56 •  Информатика

Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в турбо паскале

Ответ:
poseido2008p04tk8
poseido2008p04tk8
01.10.2020 16:45
Program picaso; uses crt;
var a,b,c,s:integer;
begin clrscr;
writeln('A:');read(a);
writeln('B:');read(b);
writeln('C:');read(c);
if(a > 0) then a:=a else a:=0;
if(b > 0) then b:=b else b:=0;
if(c > 0) then c:=c else c:=0;
s:=a+b+c;
writeln(s);
readln;
end.
0,0(0 оценок)
Ответ:
lyuda00777
lyuda00777
01.10.2020 16:45
Var a,b,c,ap,bp,cp:real;
begin
read(a,b,c);
if a>0 then ap:=a else ap:=0;
 if b>0 then bp:=b else bp:=0;
 if c>0 then cp:=c else cp:=0;
write  (ap+bp+cp);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?