В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Bioligy
Bioligy
23.09.2022 10:26 •  Информатика

Умоляю, с паскалем 1) вычислить оптимальный вес по формуле рост-100 (фактический вес v и рост h вводятся пользователем) и выдать одно из сообщений: - у вас идеальный вес; - вам нужно похудеть на n кг (n вывести); - вам нужно поправиться на n кг (n вывести). 2)составить программу, которая бы по последней цифре многозначного числа выдавала бы одно из сообщений: число не делится ни на 2, ни на 5 число делится только на 2 число делится только на 5 число делится и на 2, и на 5.

Ответ:
katenok1706
katenok1706
02.07.2020 19:26
1)
var v,h,i:real;
begin
readln(v);
readln(h);
i:=h-100;
if v=i then writeln('у вас идеальный вес') else 
if v>i then writeln('вам нужно похудеть на ', v-i,' кг ') else
writeln('вам нужно поправиться на ', i-v,' кг ');
end.

2)
var a:string;
b:integer;
begin
readln(a);
b:=strtoint(a[length(a)]);
if (b mod 2 <> 0) and (b mod 5 <> 0) then writeln('число не делится ни на 2, ни на 5');
if (b mod 2 = 0) and (b mod 5 <> 0) then writeln('число делится только на 2');
if (b mod 2 <> 0) and (b mod 5 = 0) then writeln('число делится только на 5');
if (b mod 2 = 0) and (b mod 5 = 0) then writeln('число делится и на 2, и на 52');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?