В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Cat514
Cat514
01.02.2021 04:20 •  Информатика

Напишите программу поиска максимального элемента в числовом массиве из 30 различных элементов.

Ответ:
dum3
dum3
02.07.2020 17:16
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
    srand (time(0));
    int a[30];
    for (int i=0; i<30; i++)
    {
        a[i]=rand()%30+1;
        cout <<a[i] <<' ';
    }
    cout <<endl;
    int max = 0;
    for (int i=1; i<30; i++)
      max = (a[i]>a[max]) ? i:max;
    cout <<a[max] <<endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?