В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
yulyaakimova0
yulyaakimova0
18.06.2021 01:28 •  Информатика

Составьте программу позволяющую вводить с клавиатуры 6 целых чисел и определяющую наибольшее из них. !

Ответ:
alinika2007
alinika2007
23.05.2020 16:11

Паскаль, одномерный массив

 

var a:array [1..6] of integer; i, max: integer;

begin

for i:=1 to 6 do read(a[i]);

max:=a[1];

for i:=1 to 6 do

if a[i]>max then max:=a[i];

writeln(max); readln; end.

 

0,0(0 оценок)
Ответ:
vladbb2017
vladbb2017
23.05.2020 16:11

program zadacha;

uses crt;

var a:array[1..6] of integer;

     max,i:integer;

begin

for i:=1 to 6 do readln(a[i]);

max:=a[1];

for i:=1 to 6 do if max > a[i] then max:=a[i];

writeln(max);

readln;

end.

Вроде правильно..

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?