В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
volontir00
volontir00
29.06.2022 23:01 •  Информатика

Написать программу на паскале дана квадратная матрица размером . найти сумму главной диагонали и умножить на полученное число все элементы матрицы, кроме лежащих на главной диагонали

Ответ:
Fateev20067
Fateev20067
02.07.2020 08:48

program raf105;

const

 n = 4;

var

 a: array[1..n,1..n] of integer;

 i,j,sum: integer;

begin

 for i:=1 to n do

 begin

 writeln;

   for j:=1 to n do

     begin

       a[i,j]:= random(1,9);

       if i = j then

         sum:= sum + a[i,j];

       write(a[i,j]:4,' ');

     end;

 end;

 writeln;

 writeln;

 writeln('Вывод:');

   for i:=1 to n do

 begin

 writeln;

   for j:=1 to n do

     begin

       if i <> j then

         a[i,j]:= a[i,j] * sum;

       write(a[i,j]:4,' ');

     end;

 end;

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?