В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nif4
nif4
15.12.2020 00:29 •  Информатика

Написать программу на паскале даны действительные числа x, y. определить, принадлежит ли точка с координатами (x, y) заштрихованной области.

Ответ:
Arthurkaa
Arthurkaa
02.07.2020 08:47

Если самая окружность относится к заштрихованной области, то наверное вот так. Если нет, то x*x+y*y просто <1, а не <=.

Хотя может и ошибся, я конкретно...

program aaa;

var x,y:real;

begin

    write('x?');readln(x);

    write('y?');readln(y);

    write('Tochka ');

    if (((x>=0) and (y>=0)) or ((x<=0) and (y<=0))) and ((x*x+y*y)<=1) then

       write('')

       else

           write('ne ');

    writeln('prinadlezhit zashtrihovannoj oblasti');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?