В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
123arrem
123arrem
17.03.2020 14:28 •  Информатика

Даны три натуральных числа. напишите программу определяющие существукт ли треугольник с такими длинами сторон.если такой треугольник существует то определите его тип(равносторонний, равнобедренный,разносторонний)

Ответ:
yuras12d
yuras12d
02.07.2020 06:17
Program u4i_div_and_mod;
var a,b,c,z,x,v:integer;
begin
readln(a,b,c);
if((a + b)> c) and ((a + c )> b) and ((c + b )> a)   then
begin
writeln('Yes');
if(a = b ) and( b = c ) then writeln('Ravnostor');
if(a = b) and (b <> c) then writeln('Ravnobedr');
if(a <> b ) and ( a <> c ) and (b <> c) then writeln('Raznost');
end
else writeln('NO');
readln;
end.
cорри за ин-яз просто кодировки разные,исправь где нужно)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?