В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
svetlanagilman1
svetlanagilman1
25.05.2023 16:44 •  Информатика

Спрограммой паскаль. рассмотрим целочисленный массив а[1..n] при n < = 100. написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами. ввод: число n и элементы массива вводятся из файла. вывод: в файл должны быть введены 2 вычисленных значения

Ответ:
shishovtopking
shishovtopking
01.07.2020 23:12
Программа:
const     n = 100;
type    mas = array[1..n] of byte;
var   input: text;   
output: text;   
a: mas;   
count : byte;   
i: byte;   
sum_1, sum_2 : integer;   
n_1, n_2 :byte;   
avrg_1, avrg_2 : real;
begin     
sum_1 := 0;     
sum_2 := 0;     
n_1 := 0;     
n_2 := 0;
assign(input,'in.txt');     
assign(output,'out.txt');     
reset(input);     
rewrite(output);
write('N : ');     
readln(count);         
for i:=1 to count do     
begin         
readln(input,a[i]);         
if i mod 2 = 1 then         
begin           
sum_1 := sum_1 + a[i];           
n_1 := n_1 + 1;         
end         
else
begin           
sum_2 := sum_2 + a[i];           
n_2 := n_2 + 1;         
end     
end;
avrg_1 := sum_1 / n_1;     
avrg_2 := sum_2 / n_2;
writeln(output,avrg_1);     
writeln(output,avrg_2);
close(input);     
close(output);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?