Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
микки37
04.02.2020 17:03 •
Информатика
Напишате программу вычмсления значения выражения с использованием наименьшего количества операторов: x 1,2=( -b+-rкорень из b2-4ac) / 2a
Ответ:
shorgk
01.07.2020 22:20
Program xx;
var a,b,c,x:real;
begin
readln(a,b,c);
x:=(-(b)+sqrt(sqr(b)-(4*a*c)))/(2*a);
writeln('x1 = ',x:2:2);
x:=(-b-sqrt(sqr(b)-4*a*c))/(2*a);
writeln('x2 = ',x:2:2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
zzzzzzya2017
03.11.2021 15:31
Напишите последовательность команд, с которой можно переставить значения переменных a и b так, чтобы выполнялось условие...
lizadorfv
24.12.2020 22:42
Написать программу на языке Паскаль: Создать двумерный массив размерностью 3строки и 4 столбца...
bbbbbbbbbb2
09.09.2021 12:04
Значения элементов массивов a[1..10] и b[1..10] с операторов цикла. какими будут значения a[2] и b[9] после выполнения фрагмента программы ? for n: =1 to 10 do a[n]:...
reor1878p02hjw
26.09.2021 17:55
ДОМОЖІТЬ БУДЬ ЛАСКА дуже треба терміново...
лиза4710
30.01.2021 07:03
C++Написать программу которая заполняет рандомно массив и считает сумму этих чисел...
vladchivlad
22.11.2021 01:25
С клавиатуры вводятся числа, ввод завершается числом 0. Определить, сколько было введено положительных и сколько отрицательных чисел. Пример:53-10Положительных:...
angeloknet1
27.03.2022 07:03
Запишите значение переменной s, полученное в результате работы следующей программы. var s,k: integer; begin s: =0; for k: =1 to 11 do s: =s+12; write(s); end....
jamashkinpavel
16.10.2020 23:43
Втаблице dat хранятся данные измерений среднесуточной температуры за неделю в градусах (dat[1] – данные за понедельник, dat[2] – за вторник и т. определите, что...
DesertTwo1
16.10.2020 23:43
Дан массив целых чисел, состоящий из 20 элементов, заполненный случайным образом числами из промежутка от –50 до 50. посчитать кол-во похожих элементов подсчитать...
vika2088
28.09.2022 07:08
Определите, можно рассмотривать труды поэтов Ш. Кудайбергенова и М.Копеева - как исторические источники и аргументируйте свой ответ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,b,c,x:real;
begin
readln(a,b,c);
x:=(-(b)+sqrt(sqr(b)-(4*a*c)))/(2*a);
writeln('x1 = ',x:2:2);
x:=(-b-sqrt(sqr(b)-4*a*c))/(2*a);
writeln('x2 = ',x:2:2);
end.