В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
smirnovy
smirnovy
15.02.2022 22:39 •  Информатика

Напишите программу на паскале) 1.с клавиатуры вводится 3-хзначное число. определить какая из его цифр больше. 2.с клавиатуры вводится 3-хзначное число. определить является ли произведение его цифр 3-хзначным числом. 3.с клавиатуры вводится 4-хзначное число. определить, равна ли сумма первых двух цифр сумме последних двух.

Ответ:
kiranay2007
kiranay2007
01.07.2020 18:18
program pervoe;
var a,b,c,c1,d,max:integer;
begin
readln(a);
b:=a div 100 ;
c:= a mod 10;
c1:= a mod 100;
d:= c1 div  10;
if(b > c) then max:= b
else max:= c;
if (max < d) then max := d; writeln(max);
readln;
end.
2)program vtoroe;
var a,b,c,c1,d,pro:integer;
begin
readln(a);
b:=a div 100 ;
c:= a mod 10;
c1:= a mod 100;
d:= c1 div  10;
pro:= b * c * d ;
if (pro > 99) and (pro < 1000) then writeln('Yes');
readln;
end.
3)program trete;
var a,b,c,d,e,f,g,j,sum1,sum2:integer;
begin
readln(a);
b:=a div 1000 ;{1}
c:=a mod 10;  {4}
e:=a mod 1000; {234}
f:=e div 100; {2}
g:=e mod 100;{34}
j:=g div 10; {3}
sum1:= b + f ;
sum2:= j + c;
if (sum1 = sum2)  then writeln('Yes')
else writeln('NO');
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?