В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0674167692
0674167692
07.02.2020 05:33 •  Информатика

Вас написать программу.написать программу- 1)с генератора случайных чисел создать н числа в диапазоне с [-50; 50](длину массива н надо ввести с клавиатуры) 2)надо вывести сделанный массив на экран 3)нужно вычислить и вывести,какое количество парных чисел 4)и вывести на экран все парные числа. вас нужно до завтра сделать.если можете мне, .

Ответ:
roksanaatalan
roksanaatalan
01.07.2020 14:38
Program gt;
var a:array[1..100000]of integer;
i,h,j,k,p:integer;
begin
randomize;
readln(h);
for i:=1 to h do
begin
a[i]:=random(101)-50;
write(a[i],' ');
end;
writeln;
for i:=1 to h-1 do
for j:=1 to h-1 do
begin
k:=a[j+1];
if(a[j]>a[j+1])then begin
a[j+1]:=a[j];
a[j]:=k;
end;
end;
p:=0;k:=1;
for i:=2 to h do
begin
if(a[i]=a[i-1])then k:=k+1;
if(a[i]<>a[i-1])or(i=h)then  begin
if(k>=2)then begin
p:=p+1;
writeln(a[i-1],' ',a[i-1]);
end;
k:=1;
end;
end;
writeln(p,' кол-во парных чисел без повторений');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?