В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
алинка546
алинка546
24.12.2022 00:33 •  Информатика

1. напишите программу, которая генерирует 10 случайных чисел от 1 до 20,выводит числа на экран и вычисляет их сред арифм. 2. напишите прог, в которой осуществляется ввод целых чисел,до тех пор, пока не будет введен 0 и определено максимальное из введенных чисел

Ответ:
динозаврррррр
динозаврррррр
01.07.2020 11:12
Задача 1
Var i,sum:integer;
      mas:array [1..10] of integer;
Begin 
  for i:=1 to 10 do begin         
     mas[i]:=random(20);           
      write(' ',mas[i]);           
     sum:=sum+mas[i];                   
                         end; 
writeln; 
   write('Среднее арифметическое этих чисел = ',sum/10);
End.

Задача 2 
Var i,max:integer;
Begin 
readln(i); 
    while (i<>0) do begin   
       if (i>max) then max:=i;   
          readln(i);     
                       end; 
  Writeln('Максимальное число: ',max);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?