В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
qoqo5
qoqo5
05.05.2023 12:10 •  Информатика

Напишите следующую программу. введите с клавиатуры целое число n. выведите на экран числа от 1 до n так, чтобы каждое число выводилось столько раз, каково его значение. например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6 написать программу нужно как можно проще в программе pascalabc

Ответ:
pashamironov20
pashamironov20
01.07.2020 10:17
Вообщем, сделал задачу, но метод пузырька уже не выйдет :) т.е. сортировка по возрастанию :( упрощал как мог.

Program asd;
USES crt;
Var n,m,i,j:integer;
BEGIN
Clrscr;
Writeln('Введите число n: ');
Readln(n);
n:=n+1;
For i:=1 to n do 
 begin n:=n-1; 
   For j:=1 to n  do   
     begin   
      Write(n:3); 
     end; 
end;
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?