В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу в paskal! 1) вычислите значение минимального элемента массива 2) вычислите сумму минисального и максимального элементов 3) выведите номер минимального элемента 4) выведите номера максимальных элементов и их количество

Ответ:
elvin38
elvin38
01.07.2020 08:10
Номера минимума и максимума не получается сделать паскаль выделывается чо то
var a: array[1..5] of integer; i,min,max,summa,nmin,nmax:integer;begin
for i:= 1 to 5 do readln(a[i]);
min:=a[1];for i:= 2 to 5 dobeginif a[i]<a[1] then begin min:=a[i];end;
end;
max:=a[1];for i:= 2 to 5 dobeginif a[i]>a[1] then max:=a[i];end;summa:=min+max;
writeln('min=',min);writeln('min+max=',summa);writeln('nomer min=',nmin);writeln('nomer mmax=',nmax);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?