В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anickeeva2013
anickeeva2013
19.02.2020 04:20 •  Информатика

Паскаль. в двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь один раз. нужно написать программу.

Ответ:
РукиКрабы111111111
РукиКрабы111111111
01.07.2020 07:54
Var    matrix: array[1..5,1..5] of integer;    i, j: integer; sg:=0; sp:=0;begin    writeln ('Введите 25 чисел: ');     for i := 1 to 5 do        for j := 1 to 5 do            read (matrix[i,j]);     for i := 1 to 5 do begin        for j := 1 to 5 do            write (matrix[i,j], ' ');        writeln    end;  for i:=1 to 5 do begin   for j:= 1 to 5 do   if j=i then sg:=sg+matrix[i,j]; end; for i:=5 downto 1 do    begin    for j:=1to 5 do    if (i+j)=6 then sp:=sp+matrix[i,j]    end;    sp:=sp-matrix[3,3];1 writeln(sg,' ',sp);readlnend.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?