Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
lalka133722
19.05.2023 20:36 •
Информатика
Дано натуральное число.определите количество цифр в нём.( в паскаль)
Ответ:
gavronovaanna2oz9c0h
01.10.2020 15:17
Более честный
uses crt;
var s,ans:integer;
begin
read(s);
while s>0 do
begin
inc(ans);
s:=s div 10;
end;
writeln(ans);
end.
Более короткий:
uses crt;
var s:string;
begin
read(s);
writeln(length(s));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
mazyrovavlada
31.01.2021 18:40
1. Сколько раз будет выполнен цикл forn:=1to27do? 2.Запиши программу на языке Паскаль. Вывести на экран числа от 1 до 22 в обратном порядке. var i: integer; begin...
polina4281
26.04.2020 16:24
3. Что из ниже перечисленного является видом графики? а) Пейзаж; б) Портрет в) Плакат; г) Натюрморт...
perminovdima20
19.06.2020 18:59
Перечислите функции служебных программ...
trenter
23.10.2020 11:11
Написал код, но выходные данные всегда одинаковы, почему? const randomNumber = Math.floor(Math.random() * 100); switch(randomNumber) { case (randomNumber 20) :...
yazeva006
05.01.2021 18:44
Объясните как переименовать файл...
Chvik
12.08.2020 09:40
Выполните задания из картинки ниже...
elena30lazarev
02.10.2022 02:59
Правильно ли я решила? : определить расстояние на плоскости между двумя точками с заданными координатами m1(x1,y1) и m2(x2,y2). program rastoyanie; uses crt; var...
Katerinka0307
13.11.2021 17:18
Составить текст на основе опорных слов(книга, библиотека, сочинение, техника чтения, пересказ, школа, литература)...
MilkaKamilka5
17.01.2020 08:54
Выпиши слова с парной согласной на конце и проверь . Вдруг раздался визг. У маши испуг. Из глаз потек поток слез. Это на берег выполз крепыш краб. Малыш чудо как...
kondakovvasenk
10.02.2021 08:40
Как вычислить среднегодовую амплитуду по данным Январь -35 Февраль -27 Март -23 Апрель -23 Май -9 Июнь 0 Июль 3 Август 2 Сентябрь 0 Октябрь -11 Ноябырь -21 Декабырь...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
var s,ans:integer;
begin
read(s);
while s>0 do
begin
inc(ans);
s:=s div 10;
end;
writeln(ans);
end.
Более короткий:
uses crt;
var s:string;
begin
read(s);
writeln(length(s));
end.