В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mixail1510
Mixail1510
25.04.2021 04:04 •  Информатика

Дана последовательность целых чисел a1, a2, an. составьте программу, которая выводит разность произведения элементов с нечётным индексом и суммы элементов с чётным индексом.

Ответ:
nikitalazarev2
nikitalazarev2
01.07.2020 07:21
Program gt;
var a:array[1..1000]of integer;
n,r,p,s,i:integer;
begin
read(N);
p:=1;s:=0;
for i:=1 to n do
begin
read(a[i]);
if(i mod 2=1)then p:=p*a[i] else s:=s+a[i];
end;
r:=p-s;
writeln(r);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?