В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
natalijamatijch
natalijamatijch
26.09.2021 12:23 •  Информатика

Паскаль 1) составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем. 2) составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). число n, первый элемент и разность прогрессии вводятся пользователем. вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

Ответ:
mkatty2910
mkatty2910
24.05.2020 23:23

1)

var a: 1000..9999;

      a1, a2, a3, a4: 1..9;//Цифры числа

begin

  writeln('Введите четырехзначное число');

  readln(a);

  a4:= a mod 10; //Последняя цифра

  a3:= (a mod 100) div 10;

  a2:= (a mod 1000) div 100; 

  a1:=a div 1000;//Первая слева цифра

  writeln('Произведение цифр числа: ',a1 * a2 * a3 * a4);

end.

2)

var

  n: integer;

  d, s: real;

  a1: real;

begin

  writeln('Введите число n');

  readln(n);

  writeln('Введите разность прогрессии');

  readln(d);

  writeln('Введите первый элемент');

  readln(a1);

  s:= ((2*a1+d*(n-1))/2)*n;

  writeln('Номер: ', n-1, '     Значение: ', a1+d*(n-2));

  writeln('Номер: ', n, '     Значение: ', a1+d*(n-1));

  writeln('Номер: ', n+1, '     Значение: ', a1+d*n);

  writeln('Сумма ', n, ' первых элементов равна: ',S);

end.

          

  

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?