В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
орпна
орпна
04.06.2020 03:38 •  Информатика

Pascal (паскаль составить программу сортировки массива методом пузырька но не использовать for только через repeat + использовать flag всего в программе должно быть 3 переменных: i,flag,b: integer; заранее , тому кто свяжусь и отдельно

Ответ:
bdhdt
bdhdt
30.06.2020 16:30
Program test;
const n = 5;
var i,flag,b:integer;
m:array [1..n] of integer;
begin
b:=1;
for i:=1 to n do
readln(m[i]);
repeat
b:=b+1;
if m[b]<m[b-1] then
begin
flag:=m[b-1];
m[b-1]:=m[b];
m[b]:=flag;
b:=1;
end;
until b=n;
for i:=1 to n do
writeln(i,')',m[i]);
end.

P.S. я использую for только для записи и вывода
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?