Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
vladimirnvrskp08453
09.02.2023 14:10 •
Информатика
Написать программу определения суммы цифр числа и их количества, используя оператор цикла с постусловием. программа паскаль
Ответ:
прррр11
30.06.2020 11:59
Program gt;
var n,q,s,k:integer;
begin
read(n);
s:=0;
k:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
k:=k+1;
end;
writeln(s,' ',k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
lenabogdanv1
17.04.2020 09:39
Какие есть отличия оператора while от repeat: 1) оператор while do с условием продолжения работы, a repeat until оператор с условием окончания работы 2) оператор while...
sandraustaow6o7c
17.07.2020 09:22
Какое значение примет переменная Y после выполнения программы? Var Y,X: integer; Y:=2; X=17; Repeat Y:=Y*x X=X-2; Until x 2 Writeln ( Y= ,Y); End....
Вичка11111111
11.03.2021 01:58
О чем идет речь? Изображение на плоскости при условных знаков в масштабе 1:10 000...
Coolplay
11.03.2021 01:58
ДАЮ 75 Объяснений различий в температуре воздуха января в пунктах Асуан и Рио-де-Жанейро...
Айхан111111
11.03.2021 01:58
Тевкелев елшілігінің басты мақсаты?...
тот22
02.09.2022 15:58
Тест написать правильный ответ ...
gurgurov68
02.09.2022 15:58
Что делать для улучшения качества минерального сырья...
zeka27
02.09.2022 15:58
Слова в котором количество букв и звуков не совпадает.уголь,сын,был,стол,весна....
nholodok400
02.09.2022 15:58
ХлороводородHCl получается в результате взаимодействия между водородом и хлоромCl2. Найди число молекул хлороводорода, образовавшихся в реакции, если прореагировало 10 молекул водорода....
Piloti3p6i
03.07.2022 18:19
Соч по математике 5 класс 1 четверть...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n,q,s,k:integer;
begin
read(n);
s:=0;
k:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
k:=k+1;
end;
writeln(s,' ',k);
end.